森林's Blog

心态,决定一切

ROS WIFI 802.11ac双频合一配置

0条评论 11071 ℃

近期MikroTik推出的hAP ac lite和hAP ac两款基于802.11ac的家用办公无线路由器,支持2.4G和5G双频,也就是802.11bgn和802.11ac两个协议同时工作。由于802.11ac采用5G频率覆盖范围有限,一般仅能在视距内传输,但能提供更高的带宽,如果3×3 80MHz的MIMO可以获得1.3G的带宽,如果非视距内只能通过802.11bgn来弥补。下面是关于802.11n和802.11ac的技术参数,以及hAP ac和hAP ac lite在无线MIMO的区别


...

WIN7里手动选项关闭hiberfil.sys

0条评论 832 ℃

你直接WIN键+R,在运行框里输入CMD,然后输入powercfg –h off,关闭窗口,重启,搞定


win7中的hiberfil.sys会占用大量空间(所以感觉C盘占用空间越来越大的可以试试)

...

RouterOS ADSL多线详解,无脚本更新IP,无脚本断线自动切换

0条评论 2471 ℃

前言:当你手里面有多条ADSL的时候,你会如何去利用他们呢?同时,怎么最大化利用他们呢?今天我们就来说说这个话题。


说到多线策略,就需要提及到两个概念,一个是负载均衡一个是带宽叠加。就我个人理解,负载均衡是在多个人用有限的几条线时,如何使这几条线的利用率都最大化。比如我有A、B、C、D四条线,在做负载均衡以前,可能A、B是满负荷工作,而C、D是空的;做了负载均衡以后,A、B、C、D都有流量,而不会出现一个压的喘不过气,一个没事做的情况了。带宽叠加是在一个人用多条线的时候,能将多条线的带宽加起来,从而达到提高下载速度或减少网页打开的时间。


在ROS中,以该路由器为中心,可以分为上下两部分,下面一部分是内网限速(最典型的就是DSCP Over HTB),这里不做讨论,如有需要以后分析;另一部分就是ADSL向上的那一部分,下面我就以ADSL这部分的NTH均衡来做下实例,希望抛砖引玉,希望更好的策略能够提供给有需要的读者。


在设置ADSL多线的时候,你将可能会遇到以下问题:


...

ROS中设置定时断网以及白名单

0条评论 1070 ℃

在ROS环境中,如果是用账号认证(比如pppoe,hotspot)的话,之前有份脚本,在设定的时间到了之后禁用全部账号,使其无法拨号,认证。

不过如果是DHCP分配IP或者设置静态IP来上网的话,只能借助firewall来完成。

从全局考虑,允许白名单内的用户不限时,其他的用户在到达时间后断网,此时发送的数据包全部丢弃。

这边我们设定晚上23点至次日清晨7点是断网时间,周五晚上至周六不断网,周日晚上至周四晚上断网。

限制网段:192.168.2.0/24

限制时间:晚上23点至次日清晨7点是,周五晚上至周六不断网,周日晚上至周四晚上断网


...

几个不错的公用智能DNS

0条评论 838 ℃

114 DNS:

114.114.114.114


Ali DNS:

223.5.5.5

223.6.6.6


谷歌 DNS:

8.8.8.8

8.8.4.4


这些都是我长期使用的DNS,稳定度很好。

特别推荐114和Ali。

都是公用智能DNS,适合全部运营商,走哪个运营商线路出去就会自动解析该运营商的

...

ROS防火墙过滤简介[图]

0条评论 1069 ℃

在RouterOS 通过ip firewall 能对IP数据包过滤、P2P协议过滤、源和目标IP、端口、IP协议、协议(ICMP、TCP、MSS等)、网络接口、对内部的数据包和连接作标记、ToS字节、内容过滤、顺序优先与数据频繁和时间控制、包长度控制…

从数据传输上分类:分为input、foreward和output三种链表(chain)过滤,不管是二层或者三层过滤上都包含这三个链表。RouterOS的防火墙包括了对address-list和L7-protocol等调用

快速设置向导

• 添加一条firewall 规则,将所有通过路由器到目标协议为TCP,端口为135 的数据包丢弃掉:

/ipfirewall filter add chain=forward dst-port=135 protocol=tcp action=drop

• 拒绝通过Telnet 访问路由器(协议 TCP, 端口 23):

/ip firewallfilter add chain=input protocol=tcp dst-port=23 action=drop

 


...

RouterOS新功能CAPs【ROS的AC控制功能】可以无缝网络漫游

0条评论 7800 ℃

MikroTik在14年的意大利MUM上,除了发布新的CCR、CRS和RB产品,还公布了一个新的功能——CAPs即 Controlled Access Point system Manager(CAPsMAN),通俗点说,它就是一个AP控制器功能插件,可以将任何一台RouterOS变为AP控制器,只要安装CAP的功能包(集成在wireless-fp功能包中)


它的功能就是用于集中控制你所有的RouterOS AP设备,以便快速部署大型无线网络【可以做到类似信号漫游,无缝切换,集中设置】

– CAPs管理与AP之间连接能同时工作中二层和三层网络,也就是如果你想把AC端放在某一个地方也可以集中管理远距离的AP设备的SSID,信道,密码,等配置信息。


在CAPs系统中包含数个AP(CAPsMAN代表集中管理系统,CAP代表被管理AP),CAPs为他们提供无线连接管理,维护客户端验证和数据转发

当CAP被控制管理,将建立与管理端的配置连接,通常由AP执行的如AP访问控制,客户端验证,现在交由管理端控制。CAP仅仅是维护无线连接层面的加密和解码,根据配置,数据将转发到管理端为集中处理或转发到本地的CAP。


下面我就来演示一下建立一个简单的CAPsMan管理环境


...