森林's Blog

心态,决定一切

RouterOS(ROS)简单限速/单IP限速脚本

0条评论 1436 ℃

有时企业环境,或个人使用环境需要针对不同IP设置较多条不同限速,可以使用以下脚本批量处理后,再针对性的修改。

*脚本说明:“2 to 254”定义要设置受限IP的起始,后面“192.168.1.”定义IP段。后面的设置上传和下载,”128k/2M”中128k为上传限制,2M为下载限制。



6.X版本 突发限速

:for roszj from 2 to 254 do={/queue simple add target=("192.168.1." . $roszj) burst-threshold=128K/2M burst-time=15s/15s burst-limit=256K/4M max-limit=128K/2M}


6.X版本

:for roszj from 2 to 254 do={/queue simple add target=("192.168.1." . $roszj) limit-at=0/0 max-limit=128K/2M}


...

ROS 采用NAT方式提高双线转发效率的方法

0条评论 1540 ℃

在有固定ip的情况下,NAT转发效率比masquerade高效,尤其当带机量足够多时,NAT优势十分明显,如果是双线或多线用户,更可利用NAT方式分载到不同的内网机器。因masquerade设置起来更简单,所以很少有人谈及NAT转发。其实NAT设置并不复杂,实际应用中也会更灵活。


假如有两条线路,电信接入的网卡名为TEL,网通接入的网卡为CNC,内网分配的IP为192.168.0.0/23

/ ip firewall nat 

add chain=srcnat action=src-nat to-addresses=网通线路IP to-ports=0-65535     out-interface=cnc src-address=192.168.0.0/24 comment="" disabled=no


...

ROS NAT

0条评论 995 ℃

在有固定ip的情况下,NAT转发效率比masquerade高效,尤其当带机量足够多时,NAT优势十分明显,如果是双线或多线用户,更可利用NAT方式分载到不同的内网机器。因masquerade设置起来更简单,所以很少有人谈及NAT转发。其实NAT设置并不复杂,实际应用中也会更灵活。


NAT伪装


Src-nat


...

ROS防御内网攻击

0条评论 967 ℃

本策略适用于防范UDP流量攻击(比如阿拉丁UDP攻击器)。TCP连接数攻击限制下单机连接数就行了,我就不多说了。

首先要新建一个网桥,将自己内网卡加入到桥接。


ROS防火墙脚本


...