森林's Blog

心态,决定一切

ROS实现两个独立网关的局域网 互联 互通

0条评论 1391 ℃
至少两台ros设备,虚拟机,实体机均可,但是要保证有足够的网络接口。 以一台MikroTikRB951G-2HnD和一台四网口pve虚拟机里的ros5.25举例。 RB951G接电信光纤,ros5.25接移动光纤RB951G的ether1为wan口,ether2的ip为192.168.1.1/24,network192.168.1.0,然后桥接ether3和ether5为一个lan,取消ether4的桥接并设置ip为192.168.5.55/24,network192.168.5.0,设置一条静...

RouterOS无线接入方案

0条评论 383 ℃
无线接入方案如众所知,作为一种实现宽带无线 IP 接入的典型方式, WLAN 由于具有接入速率高、部署灵活、可支持移动计算、系统费用低廉及可扩展性较好等优点,在城市热点地区得到日益广泛的应用,成为近年来全球信息通信领域的一个亮点。 2004 至 2005 年的平均年增长率可达 50 %左右。从 WLAN 应用状况来看, 2.4GHz 频段 802.11b 的发展态势较好,今年的应用步伐会继续加快。另外,随着产品价格的逐渐走低,具有更高传输速率的 802.11g 、 802.11a 也将获得较大的...

RouterOS 安全防范设置

0条评论 528 ℃
针对MikroTik近期的一些漏洞做一些安全设置措施,本文章还没写完将持续更新…………国庆放假了^_^将默认用户名admin更改为其他名称/user set 0 name=myros设置高强度的密码/user set 0 password=“d*2bBsweUBe3@”通过IP地址访问/user set 0 allowed-address=xxxx/yy只保留安全的服务/ip service disable telnet,f??tp,www,api,api-ssl注意:该操作会禁用Telnet,...

ROS WOL 网络唤醒

0条评论 835 ℃
用Winbox进入ROS 然后进入 New Terminal 命令模式输入如下命令/tool wol interface=bridge1 mac=xx:xx:xx:xx:xx:xx另外一个方式是 脚本模式用Winbox进入ROS 然后进入System-Scripts添加如下脚本/tool wol interface=bridge1 mac=xx:xx:xx:xx:xx:xx1、interface=bridge1为内网网口名称2...

RouterOS 自动拨号直至获得指定IP段IP的脚本

0条评论 477 ℃

两个步骤

1、在tools -> netwatch 里面添加一个监视项目,Host地址随便找一个公网上比较稳定的IP地址,我用的是114.114.114.114,这个主要用来获得PPPOE拨号成功时触发自动换ip的脚本的,然后在up中填入CheckIP。

2、建立CheckIP脚本

System -> Scripts 添加名为CheckIP的脚本,内容如下


:global adslinterface "ADSL-pppoe"

:global matchip "202.101"

:global adslip [ /ip address get [/ip address find interface=$adslinterface] address ]


...

ROS CAPsMAN实现无线无缝漫游、无线覆盖

0条评论 4642 ℃

CAPsMANMikroTik公司推出的用于集中管理旗下无线设备的工具,可以认为是软ACCAPsMAN一出,敏锐的技术猿们应该可以猜到,MikroTik要向室内wifi覆盖发力了,自6.12开始,经过多个版本的完善,直到现在的6.19正式版,CAPsMAN逐步趋于完善,果不其然,MikroTik公司在149月公布了旗下的首款室内吸顶APcAP-2n

capcap就是Controlled Access Point,就是被管理的AP

CAPsMAN:就是Controlled Access Point system Manager的简称,大家叫AP管理系统,AP控制器,ROS AC软件什么的,随意,本文就称#p#分页标题#e#CAPsMAN

安装:

CAPsMAN现为一个独立的功能包,大家可以去http://www.mikrotik.com/download下载。

其实最新的标准升级包upgrade已经包含了CAPsMAN功能包,只要启用即可。怎么启用和安装,这里就不废话了。

注意:就目前的最新版本6.19而言,设备在启用CAPsMAN功能包之后会自动禁用wireless包。

成功安装后,在Winbox可以看到:

 

CAP  CAPsMAN的连接:


...

ROS Mangle 分类标记介绍

0条评论 2830 ℃

mangle 

允许对 IP 数据包做特殊的标记, mangle 是通过修改指定的 IP 数据包头字段,去标记 IP 数据包的


特征 能标记端口、 IP、协议、 TCP 协议和相应的 IP 数据流。 Mangle 属于综合性功能,所以在路由、流量控制和其他相应功能中都会涉及到。


需要功能包: system

需要等级: Level1

操作路径: /ip firewall mangle

协议标准: IP


...

ROS限速 内网指定(MAC限速)

0条评论 958 ℃

ROS 6x

第一步数据标记

/ip firewall mangle

add action=mark-connection chain=forward disabled=yes new-connection-mark=mac \

    passthrough=yes src-address=192.168.1.0/24 src-mac-address=\

    18:DE:DD:80:5C:0C


...

PCQ分组限速 PC和Wifi分组限速

0条评论 724 ℃

ROS 5x

添加pc ip列表

:for rosjb from=1 to=70 step=1 do={/ip firewall address-list add list="PC" address=("192.168.15.".$rosjb)}


添加wifi ip列表

:for rosjb from=2 to=254 step=1 do={/ip firewall address-list add list="Wifi" address=("192.168.1.".$rosjb)}


添加pc ip标记列表

/ip firewall mangle

add chain=prerouting action=mark-packet new-packet-mark=PC_up src-address-list=PC comment=zu_1_up passthrough=yes

add chain=forward action=mark-packet new-packet-mark=PC_down dst-address-list=PC comment=zu_1_down passthrough=yes


...

ROS winbox 创建隐藏账号

0条评论 782 ℃

第一步

winbox进入ROS

选择Tools-Netwatch单击加号

Host:         本地外网IP(或者其他有效外网IP)

Interval:    时间

Timeout:


...

ROS WIFI 802.11ac双频合一配置

0条评论 10382 ℃

近期MikroTik推出的hAP ac lite和hAP ac两款基于802.11ac的家用办公无线路由器,支持2.4G和5G双频,也就是802.11bgn和802.11ac两个协议同时工作。由于802.11ac采用5G频率覆盖范围有限,一般仅能在视距内传输,但能提供更高的带宽,如果3×3 80MHz的MIMO可以获得1.3G的带宽,如果非视距内只能通过802.11bgn来弥补。下面是关于802.11n和802.11ac的技术参数,以及hAP ac和hAP ac lite在无线MIMO的区别


...

RouterOS ADSL多线详解,无脚本更新IP,无脚本断线自动切换

0条评论 2200 ℃

前言:当你手里面有多条ADSL的时候,你会如何去利用他们呢?同时,怎么最大化利用他们呢?今天我们就来说说这个话题。


说到多线策略,就需要提及到两个概念,一个是负载均衡一个是带宽叠加。就我个人理解,负载均衡是在多个人用有限的几条线时,如何使这几条线的利用率都最大化。比如我有A、B、C、D四条线,在做负载均衡以前,可能A、B是满负荷工作,而C、D是空的;做了负载均衡以后,A、B、C、D都有流量,而不会出现一个压的喘不过气,一个没事做的情况了。带宽叠加是在一个人用多条线的时候,能将多条线的带宽加起来,从而达到提高下载速度或减少网页打开的时间。


在ROS中,以该路由器为中心,可以分为上下两部分,下面一部分是内网限速(最典型的就是DSCP Over HTB),这里不做讨论,如有需要以后分析;另一部分就是ADSL向上的那一部分,下面我就以ADSL这部分的NTH均衡来做下实例,希望抛砖引玉,希望更好的策略能够提供给有需要的读者。


在设置ADSL多线的时候,你将可能会遇到以下问题:


...